[RESOLVED] MI3-sr13 :: Service Interruption Saturday 2nd March 2019 05:00:27


MI3-SR13 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE As of 10:05 AM EST This issue has now been resolved.  If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.