[RESOLVED] A2SS51 :: Service Interruption Thursday 28th February 2019 13:44:32


A2SS51  is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 6:55 PM EST: Maintenance on A2SS51 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.