[RESOLVED] Update Maintenance :: sgls1 Wednesday 27th February 2019 09:31:53


To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server sgls1. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available. 

UPDATE 6:55 PM EST:  Maintenance on SGLS1 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.