[RESOLVED]Update Maintenance :: nlls3 Monday 25th February 2019 07:16:55


To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server nlls3. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available.

UPDATE 3:29 PM EST Maintenance on nlls2 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.