[RESOLVED]Update Maintenance :: A2LS6 Sunday 24th February 2019 20:34:46


UPDATE February 25th 2:25 AM EST Maintenance on A2LS6 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.