[RESOLVED]Update Maintenance :: A2LS27 Friday 22nd February 2019 23:18:39


To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server A2LS27. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available. 

UPDATE February 23nd 06:15 AM EST Maintenance on A2LS27 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.