[RESOLVED]Update Maintenance :: SSR21 Wednesday 20th February 2019 18:43:32


To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server SSR21. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available. 

UPDATE February 21st 06:00 AM EST Maintenance on SSR21  has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.