[RESOLVED] SSDMAN77 :: Service Interruption Wednesday 20th February 2019 12:13:36


SSDMAN77  is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 17:25 EST: We are glad to report that SSDMAN77 is back online.