[RESOLVED] Update Maintenance :: a2ss56 Saturday 16th February 2019 20:46:00


To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server A2SS56. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available.

UPDATE As of 9AM EST This maintenance has now been completed.