[RESOLVED] az1-wss2 :: Plesk login interruption Saturday 16th February 2019 07:32:12


We are currently aware of and working on restoring service for the Plesk login functionality on az1-wss2.a2hosting.com. We will provide additional updates as they become available.

UPDATE As of 12:44PM EST This issue was resolved by our Windows team and you can now login to plesk as normal again.  Many apologies for any inconvenience caused.