[RESOLVED]Update Maintenance :: a2s84.a2hosting.com Wednesday 13th February 2019 06:16:58


We are applying updates to a2s84.a2hosting.com to ensure the stability and topicality of the server's infrastructure. We did everything possible to minimize the service downtime, but while this server is under maintenance you may still experience brief service degradation. We will post updates as they are available.

Update 2:12 PM EST: The update maintenance has completed successfully and all services are online at this time.