[RESOLVED] SSR22 :: Service Interruption Tuesday 29th January 2019 14:11:53


SSR23 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 19:45: SSR22 is back online and working normally.