[COMPLETED]Network maintenance Monday 21st January 2019 18:54:26


Start Time: 23 Feb 2019 12:00 AM Eastern 

Estimated End Time: 23 Feb 2018 4:00 AM Eastern 

Services Affected: Network 

Description: Our Systems operations team will be performing general non service affecting network maintenance. We do not expect this maintenance to have any impact on service availability.

The maintenance has started. We will let you know once it's finished.

UPDATE 4:00 AM Eastern: The maintenance has been completed