[RESOLVED]mi3-ss34 :: Service Interruption Thursday 17th January 2019 05:35:40


mi3-ss34.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 10:45 AM EST: Our System Operations team has resolved this issue and all services are online at this time.