[RESOLVED] :: A2SS29 :: Service Interruption Tuesday 1st January 2019 04:16:49


A2SS29 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 9:42 AM EST :: This server is back to full functioanality and we would like to know if you are experiencing any issues to please get in touch.