[RESOLVED] MI3-WSS3 - Email Service Interruption Wednesday 5th December 2018 10:12:07


mi3-wss3.a2hosting.com is currently some email related issues. Users hosted on this server will experience service email functionality as a result.  We will provide updates as more details are made available.

UPDATE 4:40 PM EST: We are glad to report that mi3-wss3 is behaving correctly, and this issue is resolved.