[RESOLVED]Live Chat service interruption Sunday 25th November 2018 21:11:00


Live Chat service is currently experiencing a service interruption. Our agetns will not be able to accept chat requests. We will provide updates as more details are made available.

Update 6:40 AM Eastern: Chats are back online