[RESOLVED]Domain registration/management issues Wednesday 21st November 2018 01:14:37


We are currently experiencing issues with our domain registration provider, causing errors and delays with:

We are monitoring the situation and will prove updates as soon we'll have any new information available.

UPDATE 08:00 AM Eastern: The registration provider is still having issues and we didn't receive any new updates yet.

UPDATE 3:35 PM Eastern: The registration providerĀ has implemented a fix which has restored registrations, redemptions, transfers and contact updates. Delays with EPP/Authorization Key and Domain Verification emails are slowly coming back online as well. We will continue to provide updates as quickly as possible.

UPDATE November 23, 2018 8:08 AM EST: The Registration provided has implemented a fix and all issues are resolved at this time.