[RESOLVED]Live Chat maintenance Wednesday 31st October 2018 23:21:22


Our Live Chat system is undergoing a maintenance and it is not available at the moment.

The maintenance should be completed within 1 hour.

Update o3:35 Am Eastern: The maintenance has been finished and our Live Chat service is available again.