[RESOLVED] MI3-SS30 :: Service Interruption Wednesday 17th October 2018 18:38:29


MI3-SS30 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 23:05 EST: We are glad to report that MI3-SS30 is back online and functioning normally.