[RESOLVED]Phone system not available Wednesday 10th October 2018 01:34:38


We are currently experiencing an issue with our phone system and are not able to answer calls. The issue is being looked into by our system administration team. We will provide additional updates as soon as we have more information available.

UPDATE 07:00 AM Eastern: The phone system has been fixed and we are able to accept calls again.