[RESOLVED] sr4.supercp.com :: Service Interru Thursday 6th September 2018 11:30:47


sr4.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 17:45 EDT SR4 is back online and working properly.