[RESOLVED] SSR24 :: Service Interruption Wednesday 22nd August 2018 17:45:01


The server A2SS24 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 21:50 EDT: SSR24 is back online.