[RESOLVED]A2Hosting.com :: Service Interruption Thursday 2nd August 2018 08:26:15


A2Hosting.com is currently experiencing a service interruption. Our System Operations team is currently working on this issue. We will provide updates as more details are made available.

Update 1:00 PM EST : Our System Operations team has corrected this matter and our website is loading as expected.