[RESOLVED]Multiple Michigan servers network issues Wednesday 18th July 2018 03:16:39


Michigan facility network is currently experiencing a service interruption. Users hosted there will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 07:30 AM EDT: We have identified an issue with the network and our team is working on it. All servers are up and running but can't be connected to.

UPDATE 9:02 AM EDT: Our System Operations team has corrected this matter and all services are now online. If you continue to experience connectivity issues please open a support ticket through our customer portal.