[RESOLVED] www66, 67, 68, 69, 70, 75, sr6, sr7 :: Servic Friday 13th July 2018 13:08:05


The server www66 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 17:25 EST: We have discovered that a storage server forĀ www66, 67, 68, 69, 70, 75, sr6, sr7 is offline. We are working to resolve this as quickly as possible.

UPDATE 18:10 EST: Our Engineering team is working hard to resolve the underlying problem and restore service quickly. Thanks for your continued patience.

UPDATE 19:30 EST: All systems are online except for www70. We are still working to resolve www70. Thanks for your patience.

UPDATE 19:45 EST: All systems are back online. If you continue to have any trouble, please contact our Guru Crew for support.