[RESOLVED]A2SS41 :: Service Interruption Monday 11th June 2018 18:50:17


A2SS41 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 23:04 Eastern :: We are happy to announce services are back online and responding.