[RESOLVED] AZ - Network Performance Issues Monday 7th April 2025 23:40:00


We are currently investigating reports of slowness and connectivity issues affecting services in the Arizona data center. Our team is actively working on identifying and resolving the issue. We will provide updates as soon as more information becomes available.

UPDATE 2:30 AM EST: The issue appears to have been resolved, and services are currently stable. We will continue to monitor closely. Thank you for your patience.