[Resolved] Delay in Outbound Email Delivery - MailChannels Wednesday 9th October 2024 17:13:02


We are experiencing delays in outbound email delivery via MailChannels. They have identified the issue and are currently working to resolve it. We will provide updates as soon as more information becomes available.

Update (5:23 PM ET): MailChannels continues to address the problem and is in the process of clearing backed-up emails from their queues.

Update (6:25 PM ET): The incident has been successfully resolved, and all emails in the queue have been cleared. If you encounter any further issues, please don't hesitate to contact Support.