[COMPLETED] Scheduled Maintenance :: sg1-ts7 Tuesday 24th September 2024 08:09:13


Start time (EST): September 27th, 2024 @ 13:00

End time (EST): September 27th, 2024 @ 14:00

Description: Our System Operations team will be performing scheduled maintenance on this server. Users will experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 1:12 PM ET: The maintenance has been completed.