[RESOLVED]Connection issues | NX_DOMAIN errors | Multiple services Thursday 12th September 2024 07:49:35


We are receiving reports from clients mostly in Malaysia, Portugal, India, Germany, and Morocco who are experiencing issues accessing our services. Based on our findings, the problem appears to be related to external ISP's DNS servers.

While we have limited control over external ISPs, we recommend that affected customers switch to public DNS servers like below temporarily to access the services.  

Google DNS: 8.8.8.8

Cloudflare DNS: 1.1.1.1

Additionally, you may also need to clear your DNS cache. Instructions for this can be found in the following article: 

https://www.a2hosting.com/kb/getting-started-guide/internet-and-networking/clearing-the-dns-cache-on-your-computer/

UPDATE 10:15AM: This issue appears to be resolved at this time. If you are still experiencing any issues connecting to your servers, please reach out to our Support team.