[RESOLVED] Network issue :: AZ servers Wednesday 28th August 2024 05:18:22


We are aware of network issues currently linked to our Arizona servers. Users hosted on some servers in Arizona will experience service degradation as a result. Our System Operations team is investigating the cause of this interruption. We will provide updates as more details are made available. We sincerely apologize for any inconvenience faced in the meantime.

UPDATE 05:50 AM EDT: Our System Operations team resolved the issue, the network is stable and fully accessible. If you notice any problems, please, reach out to our Support. Thank you for your understanding and patience.