[Completed] Scheduled Maintenance :: mi3-tr1 Tuesday 27th August 2024 00:45:09


Start Time (EST): 1:00 AM 

End Time (EST): 3:00 AM 

Server/Service: mi3-tr1

Description: Our System Operations team will be performing scheduled maintenance on this server. Users will experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

Update: The maintenance is in progress.

Update: The maintenance has been completed.