[RESOLVED]Emergency Maintenance :: mi3-ss32 Wednesday 21st August 2024 09:04:38


Services Affected:  mi3-ss32 

Description: Our System Operations team will conduct Emergency Maintenance on this server. During this time, users may experience a brief service interruption. We'll keep you updated on any developments.

UPDATE 9:30AM EDT: The maintenance is still in progress. Our System Operations team is currently working to resolve all issues on the server. We will provide further updates as they become available.

UPDATE 10:30AM EDT: The maintenance on mi3-ss32 has been completed and services are once again available. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.