[COMPLETED] Arizona Datacenter :: Scheduled Maintenance Thursday 25th July 2024 02:54:16


Start time (ET): July 25th, 2024 @ 03:00

End time (ET): July 25th, 2024 @ 07:00

Description: Our System Operations team will be performing scheduled maintenance on our Arizona DataCenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE: The maintenance has been completed.