[COMPLETED] nl1-vz7-vu12 :: Scheduled Maintenance Friday 19th July 2024 21:29:21


Server Time: July 22, Monday 02:00 AM CET 2

EDT Time: July 21, Sunday 08:00 PM EDT

Description: Our Engineering team is scheduled to perform Scheduled maintenance on VPS node  nl1-vz7-vu12. Users on the same VPS node may experience a brief service interruption during this routine maintenance.

UPDATE 8:00 PM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 8:14 PM EDT: The maintenance has been completed.