[Resolved] CrowdStrike outage Friday 19th July 2024 15:07:44


CrowdStrike, a security vendor for many large companies, has been experiencing an outage impacting banks, payment processors, Domain Registrars, flights, TV, and gaming.

This includes our registrar partner eNom, users are unable to update nameservers or other domain services at this time. eNom is providing updates on this event here:

https://enomstatus.com/incidents/1579t7gnt01r

UPDATE: Our registrar partner eNom has reported that this incident has been resolved. If you have any questions, please do not hesitate to contact us.