[COMPLETED] mi3-ss64 :: Scheduled Maintenance Thursday 18th July 2024 03:00:00


Start time (ET): July 18th, 2024 @ 04:00

End time (ET): July 18th, 2024 @ 05:00

Our System Operations team will be performing scheduled maintenance on the mi3-ss64. Users on this server will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: The maintenance has been completed.