[RESOLVED] sg1-ss15 : Service Interruption Sunday 7th July 2024 23:35:10


We are currently experiencing a service interruption on server sg1-ss15. Users hosted on this server may experience service degradation. Our system engineers are actively investigating the root cause of this issue. We will provide updates as soon as more information becomes available. Thank you for your patience.

UPDATE: 04:00 AM EDT: Our Engineers are addressing intermittent slowness and interruptions on the server. Thank you for your patience and understanding.

UPDATE 05:30 AM EDT: Our Engineers were able to resolve the problem. We are closely monitoring the server's stability and performance. Please contact Support if you face any issues.