[Completed] Emergency Maintenance :: MI DataCenter Tuesday 25th June 2024 00:11:24


Services Affected:  MI DataCenter

Description: Our System Operations team will conduct Emergency Maintenance on the MI DataCenter. During this time, users may experience a brief service interruption on a small subset of servers. We'll keep you updated on any developments in this thread.

UPDATE 12:40 PM EDT: This maintenance is now completed.