[COMPLETED] Emergency Maintenance :: MI DataCenter Thursday 20th June 2024 23:50:17


Services Affected:  MI DataCenter

Description: Our System Operations team will conduct Emergency Maintenance on the MI DataCenter. During this time, users may experience a brief service interruption. We'll keep you updated on any developments in this thread.

UPDATE: The Maintenance is now started.

Update: The maintenance is completed.