[RESOLVED]Emergency Maintenance :: mi3-ss60 Tuesday 18th June 2024 01:10:30


Services Affected:  mi3-ss60 

Description: Our System Operations team will conduct Emergency Maintenance on this server. During this time, users may experience a brief service interruption. We'll keep you updated on any developments in this thread.

UPDATE 1:30AM: This maintenance was completed. Services are online once again.