[COMPLETED] Arizona Data Center :: Scheduled Network Maintenance Wednesday 12th June 2024 23:22:18


Start Time: June 13, 2024, at 3:00 AM EDT

End Time: June 13, 2024, at 6:00 AM EDT

Description: Our System Operations team will perform scheduled maintenance on the Arizona Datacenter. Users may experience a brief service interruption during this routine maintenance. We will provide all updates related to this maintenance in this thread.

03:00 AM EDT: The maintenance has started.

UPDATE 06:10 AM EDT: The maintenance is completed.