[RESOLVED] mi3-sr19 : Service Interruption Monday 10th June 2024 15:34:57


We are currently experiencing a service interruption on server mi3-sr19. Users hosted on this server may experience service degradation. Our system engineers are actively investigating the root cause of this issue. We will provide updates as soon as more information becomes available. Thank you for your patience.

UPDATE 03:45 PM EDT:  We're pleased to inform you that our system engineers have successfully identified the root cause of the service interruption on the server and have implemented the necessary fixes. The server is now back online, and services should be operating normally.