[RESOLVED] sg1-tr3 :: Service Interruption Sunday 9th June 2024 01:35:18


We observe intermittent connection issues when accessing sg1-tr3 server. We are actively investigating the matter. Your patience is highly appreciated.

UPDATE 02:50 AM EDT: Our Engineers were able to find the root of the issue. The load and the performance have been stabilized. If you notice any issues, please reach out to our support.