[COMPLETED] Michigan DataCenter : Emergency Network Maintenance Thursday 6th June 2024 23:57:59


Date: 06/07/2024

Start Time (EST): 12:00 AM EST

End Time (EST): 2:00 AM EST

Description: Our System Operations team will conduct Emergency maintenance on the Michigan Datacenter during this period. Users may experience a brief service interruption while routine maintenance is performed. We'll provide all updates related to this maintenance in this thread.

UPDATE: The maintenance was completed.