[RESOLVED] mi3-sr109 : Service Interruption Wednesday 5th June 2024 22:28:47


We are currently experiencing a service interruption on server mi3-sr109. Users hosted on this server may experience service degradation. Our system engineers are actively investigating the root cause of this issue. We will provide updates as soon as more information becomes available. Thank you for your patience.

Update 12:00 AM: Our Engineers were able to find the root of the issue and were able to stabilize the load and the performance. If you notice any issues, please reach out to our support.