[COMPLETED] Scheduled Maintenance :: MI Datacenter Friday 31st May 2024 01:11:27


Date: 05/31/2024

Start Time (EST): 12:00 AM EST

End Time (EST): 3:00 AM EST

Description: Our System Operations team will conduct scheduled maintenance during this period. Users may experience a brief service interruption while routine maintenance is performed. We'll provide all updates related to this maintenance in this thread.

The maintenance appears to be taking longer than expected. We will update the thread as soon as it is completed. 

UPDATE: The maintenance for today is now completed.