[COMPLETED] Arizona DataCenter : Scheduled Network Maintenance Wednesday 22nd May 2024 07:47:19


Date: Thursday, May 23

Time: Time: 03:00 AM - 07:00 AM EDT (12:00 AM - 04:00 AM PST)

Description: Our System Operations team will conduct scheduled maintenance on the Arizona Datacenter during this period. Users may experience a brief service interruption while routine maintenance is performed. We'll provide all updates related to this maintenance in this thread.

3:00 AM EDT: The maintenance has started.

UPDATE: The maintenance was completed.