[COMPLETED] MI DataCenter : Scheduled Network Maintenance Thursday 16th May 2024 00:52:16


Start: 16 May 12:00 AM ET

End: 16 May 03:00 AM ET

Description: Our System Operations team will be performing scheduled maintenance on the MI Datacenter. Users may experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: The maintenance has started.

UPDATE 03:00 AM ET: The maintenance has been completed.